Trying to check for changes, getting no data or SELECTION_EMPTY error

That’s the web page. The Selector is the top Headline or Alert# on the page., but it’s not working. Either empty or SELECTION_EMPTY error.

Using Firefox for this .

Tried it using the distill cloud page, and it seems to handle it better, but not 100% sure its working either, at least not throwing the error.

Any help in getting this working would be appreciated.

Hello @loupastern - I am not sure what the headline is. Is it the page’s title displayed in the header?

Can you try using the desktop app and see if that is able to monitor the page? Let me know what you find out.

Its the headline as pictured here from this link. I would be checking for changes to the top headline (looking for new entries )

Following config works using the browser extension:

  "selections": [
      "frames": [
          "index": 0,
          "excludes": [],
          "includes": [
              "type": "css",
              "expr": "tr:nth-child(2) td:nth-child(4)",
              "fields": [
                  "name": "text",
                  "type": "builtin"
      "dynamic": true,
      "delay": 5
  "ignoreEmptyText": true,
  "includeStyle": false,
  "dataAttr": "text",
  "regexp": {
    "expr": "",
    "flags": "gim"

Can you try this out and if it works for you?

Tried using that config , but it does not work for me. Getting the same error

I dont know enough about coding for this type of web page to know what the issue is.

I see. Can you try using a different device and see if that works?

Another question: is the page opened in a tab to be checked for changes or is it forced to be checked in background? When in background, the page’s JavaScript can’t run to update dynamic parts of the page.

The scan works on the cloud version as you can see

Javascript is enabled on the Firefox browser version.

Thanks for the update. Can you test other browsers, or the desktop app?

I tested in Vivaldi and it seemed to work.

Then tested in a clean Firefox profile , and it seems to work there as well.

So must be some interaction with one of the many add ons I use. Never ran into this issue before and Ive used Distill for years. So I’ll have to narrow down the problem .

Thing is , if the page loads normally in the same browser , then why would Distill have a problem ??

If you have any ideas, would appreciate hearing them

It is interesting for sure. Can you test this in Firefox by creating a new profile? Checkout following article to learn more about how to create and use additional profiles in Firefox:

Do let me know what you find out. Thanks!