Troubleshooting email and text notifications when web page changes

Hi I’m new so am prob missing an obvious step. I’ve set up a profile for a login-protected web page. I’m using your pooled server, which asked me to log into my google account. After I did this, the protected page in the URL I provided in your form appeared. Not sure how it knew to log in (with my username/pwd for the site) but maybe there’s a cookie with the pwd in it? (If so, how do I know when that cookie expires?)

Since I could see the web page, I assumed I was ready to add notifications to my email and phone to my dashboard for that profile. I did, but about an hour or so later, the web page changed, but I didn’t receive any notifications from Distill. Any advice? Thanks!

Hi @branch

Firstly, welcome to Distill’s forums.

If the cookie expires, then you will end up receiving a change notification where you’ll usually see the login page being displayed (instead of the one you are trying to monitor). It might also end-up with a SELECTION_EMPTY error, if the selected element is not present on the loaded page.

Once you have saved a profile, you will still need to go ahead and create a monitor for the page by associating the profile. I’d recommend watching this YouTube tutorial video to understand the setup better.

Please feel free to reach out, if you still face any issues.


Thank you Surya,

I decided to start fresh and follow the YouTube tutorial. This time, for the profile, I used the login page to the actual website I want to go to. I was able to type in my username but it will not allow me to type anything in the password field. Nothing happens when I hit the keyboard. I tried using Chrome, and Firefox. Neither worked. Any advice? Thanks.

Hi @branch

Can you please share the URL of the website?


PS I can also send you screenshots of the login popup for the site.


I am able to click the pop-up and also enter details on the remote browser:

Can you kindly share some screenshots to better understand your challenges?


Thanks. I found the problem. The site does not allow me to use my numeric keypad. So I was able to use the typewriter portion to enter the numbers in my password.

I believe I’m all set up now. I won’t know until tomorrow if the monitor is doing what I need.