Returning partial numbers as match after new update (19/07) among other problems

Since today I have been experiencing problems with the software matching partial numbers.

Lets say I am scanning a website for product prices under 21,000
New listings are coming in constantly, all starting starting with the number “2”.
Now there are listings for 25,000 25,000 23,000 in one search.
Next time the search is conducted, listings are 24,000 25,000 25,000 23,000
The software now matches 24,000 as 4,000 since technically the leading 2 is not a new number.

Another problem I have been experiencing is that while before I was searching in two elements of CSS: outerHTML but now it always turns the second CSS into XPath and does not allow me to search for outerHTML or any of the other attributes that were previously avilable. It only allows me to search for text.

Third problem, Every time I open my monitors to edit the element selector, the regular expression is removed.

Is there any way for me to install the previous version?

Hi @skurkurskanni, thanks for reaching out and reporting the issue. For filtering numbers, what regular expression are you using?

Are you using the desktop or the extension? I recall that one of the issues was fixed in an older update. It will be help if the app is updated to the latest version.

I am using chrome extension that updated yesterday. Version: 3.6.8
I have both tried searching for the element itself with CSS, Text: span[data-bind=‘Number: Price’] using no regular expression and it also happens there.

But since i’m trying to detect if captcha is triggered also and have to use regex, so for that I use

(?<=id="captcha-modal" role="dialog" data-backdrop="static" data-keyboard="false" )(.*)(?=include)|(^\d{1,3}(,\d{3})*(\.\d+)?(\n)?) /gim

I have both tried searching with and without the newline character.

As seen below the search looks good in visual mode, but when you switch to text you can see how it is matching between spaces.

Are you referring to how the changed content is highlighted in green?

Please note that the way changes are highlighted is done after the text has been filtered out from the page. This includes using regex to filter text content.

The bug where selector’s type changes automatically to XPath in the visual selector panel was fixed before 3.6.5. I tried to reproduce but couldn’t. Are still encountering this? If yes, can you please share the monitor’s config and URL to help reproduce that?

Hey, sorry for not replying sooner with a copy of the config.
But this appears to be fixed now in version 3.6.10, second CSS selector is not changing to XPath anymore and regex filter is showing up.

About the highlight however, I was pointing out that partial numbers were being detected as a whole number. See 25,930 in the text view seems to be recognized as 930 or 31,000 as 31 triggering “added text has number below (<) 22000” with number format A: 1,000,000.00

At least this search is being triggered as below 22000. Even in newest update.

I have however worked around this by selecting outerHTML with no regex filter and match being:
added text matches regular expression: (?<=>)(([1-9]|[1][0-9]|[2][01])(,))?([0-9]{0,3})(\.[0-9]{0,3})?(?=<)
Matching 0-999, with up to 3 optional decimal points, and optional thousand separator (,) with either 1-9, 10-19 or 20-21 in front. Only matching if between > and < (closing and opening tag in html)