Macro recorder not loading a URL

I’d like to record a macro for the following site:

It doesn’t open in the macro recorder. What can I do?

  1. What is a non-URL?

  2. Can you share more details about the problem you are facing? I tried to record a macro. Seemed to work as shown below:


Well, I meant an internet address that doesn’t have a https in front of it. Pardon my untechnical language.

The screenshot you’re showing is the right page. On my application, the site doesn’t open at all in the macro recorder.

Thanks for the clarification.

The link pasted in the first post started with https. I tried opening the recorder with that URL 5 times just now. It loaded the page in 10-15 seconds on each try.

  1. Are you facing this issue for other URLs too?
  2. What do you see if you open that URL in a visual selector?

1.I don’t think so.
2. In the visual selector, it works.

I am wondering if it has something to do with the browser or the network. As a test, can you open an incognito window to sign in to the Watchlist and open the recorder?

Please create a screen recording using Loom and share the link here in case it doesn’t work.


I tried to record something with Loom in incognito, which didn’t work. However, after I cleared the Google cache, the site loaded, dont know why. I have another item still open, for some time already, how can I make someone aware of it? Just post something there again.

This can be done using Loom’s desktop app for screen recording.