How to stop monitors running mutliple times on start up

Just wondering why my monitors run 3+ times concurrently when I first start Chrome, usually first thing in the morning. Is it “catching up” scans that haven’t run while the computer or browser has been off? Is there a setting to change this behaviour?

1 Like

Just bumping this.
If anyone can help please.

@Stuckster Upon launching Chrome, the system initiates checks for all monitors that were scheduled to check when the browser was not up and running.

By default, three concurrent workers simultaneously check the first three monitors in the queue. Following this, the workers sequentially address each remaining monitor in the queue until every monitor in the queue has been checked.

If you want to check only one monitor at a time, you can set the concurrent workers to one from Settings ->Advanced option. Alternatively, follow the link chrome-extension://inlikjemeeknofckkjolnjbpehgadgge/ui/inbox.html#/settings/advanced/ → Maximum number of concurrent workers → 1

1 Like

Awesome. Thanks. Will give that a try.