Тhe selector does not work

I am trying to monitor ads change on this site: https://www.xior-booking.com/#.
I have tried using cloud server, desktop app and firefox extension.

1. On cloud server
When I edit the selector all seеms to work fine, it shows ads as expected.

But when the monitor runs, it does not show any ads.

2. In desktop app and in firefox
Selector initially works. But I need ads only for specified city and have recorded a macro to select a filter option.
In macro recorder my macro works fine.
desctop app macro recorder works

But when monitor runs, macro stop working and no filter are applied.

Hi @isblank, what error does the monitor log when it starts to error out? I tried following what your steps and it seemed to run and work correctly in cloud:

Note that I added a delay of 10 seconds as shown below:

Can you try these out and see how it works? If it errors out, please share a screenshot of the page’s snapshot if any was captured. It might offer a clue. Thanks!

Hi, thanks for fast response :slight_smile:

I added wait for 25s and still not working.
No errors, this morning the site was too busy, so some TIMEOUT occurred, but now works again.

If timeout is a problem, try reducing the wait time to a smaller value like 7 or 10. Cheers!

Setting wait time to any value does not help.
I’m about to give up and have no clue what else to try.
Maybe the problem is with my Starter plan.
Maybe a Professional or Flexi plan will work fine.
I think it’s a good idea to give you access to my account so you can look into the problem that way.
Ajit, would you accept?

A higher tier won’t help. Let me check if local monitoring will work better here and get back to you.

Hello @isblank

We have been testing the same from our side and found an issue within macro and have deployed a fix. Could you please update the app (to 3.9.17-beta) and try running the monitor again? Also make sure to select the page title (or ay other content that always appear) so that the monitor won’t error out when the selected city has no results.

Sorry we couldn’t find this out earlier and you had to go through additional steps to test the macro.

As for the monitor you can remove the 25 second wait. You could add a 2-5 second wait in the macros (wait_for_duration in macro) after the select step to get the correct results as I noticed the results appear after a delay for a slower internet connection.



Now it works on the desktop app!
Thank you, jayakrishnan !
Thank you, Аjit