Enable / Disable monitoring on desktop app

I rebooted my computer to install Microsoft updates and now the desktop app won’t check for updates, despite the time slots for checks remaining unchanged.

How do you enable or disable monitoring on the desktop app? I don’t see any option like I do with the browser extensions.

I’m on the starter plan and I updated the app to the latest version today just to rule out the obvious and it did not resolve the issue.

1 Like

Hello @rickyriv, thanks for reaching out and help test the desktop app. Can you please share the installed app version?

By unchanged, do you mean that the time slots were not set and is using the default value?

We dodn’t add this feature because it can be done easily by closing the app (unlike the extension). But if you think that there is a need to manually enable or disable monitoring for the desktop app, let me know.

When you go the Watchlist, and try to check a monitor for changes, does is start checking that monitor for changes or does it show an error message?

App version: 3.6.6-alpha

By unchanged, what I mean is that the time slots were the same configuration as they were before the reboot & app upgrade. Based on the settings, the app should be monitoring and it is not.

The reason for the manual enabling on the extensions is so you can easily turn off the monitoring while having the extension open and without having to change the time slots for monitoring. In this situation, it would be nice to have so that I can force the app to start monitoring again when it seems to be stuck in a situation where it stopped monitoring and nothing I change gets it to start monitoring again. Underneath the time slot settings, it does say “for paid customers” but I am signed in to the desktop app with a paid account.

When you go the Watchlist, and try to check a monitor for changes, does is start checking that monitor for changes or does it show an error message?

No, switching a monitor on or off does not get the app to start monitoring again. I have tried uninstalling & reinstalling the app and signing out and back in.

Since the desktop app has no option to manually enable/disable monitoring, am I to uncheck the time slots so that it is always monitoring, or do I enable time slots and then choose the entire day and all days for monitoring to effectively “turn on” monitoring and monitor 24/7?

I meant forcing the check manually as shown in the following screenshot:

The device for the monitor in screenshot is set to “this device” as shown below:

Regarding time slots, can you disable the time slots and see automated checks work?

When I selected “check for changes” in the desktop app, I received a red error banner up top that says "Checks are paused; Click Distill icon in the browser toolbar and click ON to start checks. Do you know what browser toolbar it is referring to? The Distill browser (which opens when you click a link from the desktop app) doesn’t have a Distill icon to click on. And I don’t see any Distill icon on the desktop app itself that I can click ON to start checks.

I’ve turned the time slots on and off and enabled 24/7 monitoring from there and it didn’t make a difference. The issue seems to be above, but I don’t know where it is telling me to manually turns the checks back on.

1 Like

Thanks for the screenshot. This looks like a bug in with the way it handles time slots. We will fix this soon. Will let you know once the update has been released.

Updating to 3.6.7-alpha today seems to have resolved the issue. The only new issue I am having is that even with the time slots configured, checks are still happening after hours at a time when checks should be disabled per the settings.

1 Like

Thanks for the update @rickyriv. We just released 3.6.8-alpha. Can you check if this fixes the problem with time slots? You may have to update the time slots setting for it to take effect.

I upgraded to 3.6.8-alpha (happened automatically by closing & reopening the app) but when I uncheck the “enable checks by time slots”, checks continue to occur.

When I check the time slots option and set it for range outside of the current time for when it should be disabled, checks do not occur, so the schedule seems to be working as expected.

With this behavior, how do we turn off all checks while still having the app open or without having to set the time slots to a time outside of the current time? For me, the helpful part of the manual on/off for checks like the extension has is for this very reason - being able to work on the app and add new monitors etc without having it running checks at the same time. This is more helpful with the browser when you’re adding new monitors and new tabs are opening up for checks while you are trying to work on adding new monitors.

I couldn’t reproduce the problem. Can you try to update the schedule in the time slot and try again? Note that you may have to wait for a minute or two after making the change. Let me know if that works (or doesn’t). Thanks!

I unchecked the time slots and waited 2+ minutes and checks continued to occur. Not sure if this behavior is unique for my setup but this is the behavior I am experiencing. It is not a big deal for me because the workaround is to change the time slots to a time frame other than the current time and effectively disable the checks for as long as I need, and then change the time slots back after to my regular monitoring schedule.

Overall, happy with the desktop app so far and thank you for the helpful support!

1 Like