Downloaded macro fails at last step

i tried downloading the macro that is recommended in this section to monitor US visa dates for an appointment, I already edited it with my credentials. When I replay it, it goes smoothly and gets to the date grid just like I want. But when I add the macro to the monitor, everytime there is an ERROR flag that says it failed at “click” and, the error shows just the last step, the one to click on the menu Dates to show the grid. How can I fix it?

thank you for your help

1 Like

Welcome to the forum @magicyasmin.

The error indicates that it tried to find click element identified by selector [type='email']. There is no email field in this step. Can you please double check the macro once to see if there is such a step towards the end of the macro? Let me know what you find out. Cheers!

thank you for your response

I have checked and there is not, the only “email” command is at the beginning

here is the list of steps that run smoothly toward the end:

what am i doing wrong?

I am checking the logs now. There was a macro named us visa that that had this step at the end:

            "meta": {},
            "type": "css",
            "value": "[type='email']"
        "x": 187.91319274902344,
        "y": 15.6180419921875
        "frame": 0

Let me see if I can create and share a macro for you.

Can you try using the following macro and let me know how it works?

visa-pe-d16e97cc-855d-11ee-9bfe-23ccc9f87d27.json (2.4 KB)