Desktop app stops checking locally

Hi there,

I am using desktop app to check around 5000 monitors, most of which are daily.
It works sometimes, but it seems to slowdown in checking for changes as the app runs for a while. And a lot of monitors are not checked as often as they should be.
Sometimes it even stops checking for hours, so I need to restart the app so it runs again.

Is there a way to prevent the slowdown?
thanks!

@Steyn thanks for reporting the issue. make help us with a few metrics:

  1. how many concurrent workers are being used?
  2. what is the ram and cpu usage of the app when it starts to feel slow.

a lot of monitors are not checked as often as they should be.

  1. what does the log look like for monitors that should be checked daily? or, are these monitors using a lower check interval?

thanks for the reply.

  1. 10 concurrent workers are used for checking.

  2. it seems to keep an extensive amount of workers working when it’s slow.

  3. The logs show that the last check was a couple of days ago regardless of the intervals.

Please feel free to let me know if you require any further information.

thank you

Hello @Steyn,
Thanks for providing more info about the errors.

it seems to keep an extensive amount of workers working when it’s slow.

Are you running static monitors (monitors with JavaScript disabled) as well? We were able to find a scenario with static monitors where this happens and implement a fix.

Also note that some of the processes takes some time to get killed (processes like Service workers in a page). A total of around 6-8 processes are bound to run when the app is active and not running any monitors.

Hi @jayakrishnan ,

I think all the monitors are java enabled by default. And we did not change it.

Thanks!

Hi @Steyn,

Could you check if the latest version of the app (3.10.12) also has the same issues mentioned above. Also note that setting the number of monitors in the watchlist to more than 200 slows down the Electron App UI. Something we are currently working on to fix.
The settingI am talking about is the “Page size” option in the top-right “Setting/Cog” menu dropdown in the watchlist.

Thank you