Delay in closing already checked tabs in sticky window

Hello, i really hope you can help me with this.

i observed the following issue that is severely limiting the speed in which i can check websites:

The tabs open and load at expected speeds but they stay open for a good 10 or more seconds (sometimes 20 or 30 seconds) after they finished loading.
When i open the sticky window and manually click on the new tabs and ‘watch’ them load, they close within a fraction of a second (as they should).
However, when ran in the background without me watching the sticky window opening and closing its tabs it takes 10 or more seconds to close.

This happens with all browsers i tested (Chrome, Firefox, Opera) but is the most prominent in Firefox.
My PC and connection could easily handle 20 or more checked sites every 5 seconds but because the idle tabs clog the queue i only manage to pull off maybe 20 checked sites every 30-60 seconds.

The checks are ran on my device (Windows 10)

Any ideas how i can prevent those sites to idle for an eternity in the sticky window after the check is already done?

Thank you in advance

I made two gifs to give you some visual clues what i mean:
When i let the sticky window do it’s own thing it keeps tab open despite having loaded instantly:
(results in sub par speed/volume of checks)

When i click on the tabs to bring them to the foreground, they immediately close when finished loading:
(results in optimal speed/volume of checks)

Note that in the second video i am not closing the tabs, i am just clicking on them to open them, they close on their own once loaded. I would like to see the same speed when the Sticky window is operating in the background, because for obvious reasons i can’t manually click on the tabs for hours, that would defeat the purpose of an automated monitor.


Hello @lagavulinlover59, nice gifs! Welcome to the community forum.

Recent versions (since 2021) of browsers have started throttling the page loads in background tabs[1]. This could be one of the likely reasons that can delay JavaScript execution in a page.

Are those pages dynamic (needs JS to render DOM)? If not then you can disable JS by setting dynamic to false in config. That should result in much faster checks.

As an experiment, can you try using the “window” for checks temporarily with a maximum of 1 concurrent workers? Do the pages load quickly there? This is not recommended as a solution because of how disruptive opening new windows is. But it will help understand the behavior.


[1] Chromium Blog: Tab throttling and more performance improvements in Chrome M87

Hello @ajitk, thank you very much for your swift reply!
It might be just the browsers throttling, but it doesn’t seem to throttle the loading at all because the tab shows it’s finished loading after a few milliseconds, but the tabs simply don’t close as fast as they should.
Also i made sure throttling was disabled in all browsers.

The content seems to be all dynamic, because when i set it to false it instantly produced lots of “SELECTION_EMPTY” errors.
When i did what i suggested my entire watchlist collapsed, even after i turned it back to true. Every check keeps returning only “SELECTION_EMPTY”, even 30 minutes after returning to my old config settings. Restart of Chrome doesn’t fix it.
When i set my Chrome Watchlist up fresh the checks work but the tabs still don’t close, even after minutes of them idling.
My Chrome watchlist seems to be fully destroyed somehow by setting it to false only once somehow…
I’ll try reinstalling the browser addon and restarting my PC

Here is my config, it’s pretty much the default:

“selections”: [
“frames”: [
“index”: 0,
“excludes”: [],
“includes”: [
“type”: “xpath”,
“expr”: “//div[@id=‘app’]//div[contains(@class,‘body’)]/div[@class=‘container’]/div[@class=‘page-canvas’]/main[@class=‘main’]/div[@class=‘product’]/section[@class=‘section’]/div[@class=‘wrapper’]/div[@class=‘content’]”
“dynamic”: true,
“delay”: 2
“ignoreEmptyText”: true,
“includeStyle”: false,
“dataAttr”: “text”

I have exactly the same settings as before, i don’t know what happened but now the tabs dont close at all anymore. I could make a new gif but it would just be a pictore of nothing happening.

I tried out setting the workers to 1 and opening it in a new window. It appears to load a little faster but it’s basically the same phenomenon here:
Pages take roughly 6-7 seconds to open and close when i run it in the background and use another browser to surf the web, but as soon as i open the browser i run the checks in, the new windows load in 1-2 seconds instead of 5-6.
It is as if the checks goof off whenever i don’t watch them and as soon as i bring them on my screen they do what they are supposed to.

Restarting my pc in conjunction with re-doing all the monitors seems to have fixed it all the errors. The tabs still close slow as heck in all browsers, but i guess i’ll stop playing around with it for now.

Sorry to see you go through so much of trouble to revert back to dynamic checks. I noticed and instead of " characters in the config json. Some text editors convert quotes from one form to the other form automatically which makes the json invalid.

The tabs that take time to load, it is because browsers try to reduce resource usage of the background tabs and slows them down. The favicon looks loaded because initial load of the page is done. The JavaScript that run in the page are slowed down. When they are selected and made active, the JS execution is sped up automatically by the browser.

Can you try disabling throttling using the following tutorial?