Changing Timeout Length

I’ve looked everywhere I an think of and can’t find a way to change the timeout setting when checking for changes. It seems like this would be a common setting as some website can take a while to completely load, especially if the internet connection is very slow.

Thanks if advance for any help y’all can provide!

1 Like

I have the same issue. Also when investigating I can see that the page I am trying to monitor doesn’t load fully when it tries to check for changes, but when I click on the tab all content is loaded (in another container for example)

1 Like

@SPDurkee Welcome to Distill community!

Here are the options that you can try based on your page:

  1. If you’re dealing with static content that requires monitoring, consider setting the dynamic parameter to FALSE in the config. This adjustment can enhance the loading speed of static pages, particularly beneficial when dealing with slow internet connections.

  2. If the content you’re monitoring takes more time to load, there’s a possibility that Distill might encounter a “Selection Empty error” if it checks the page too quickly. In such cases, increasing the delay value in the config (up to 20 seconds) can help.

  3. If slow page loading is attributed to a sluggish server or poor internet connectivity, you can incorporate the timeout parameter in the config. This parameter allows you to modify the default timeout value (set at 30 seconds) for the monitored page. It’s important to note that this parameter works for the local monitor. To include a timeout parameter in the config, please refer to the example below. The timeout value is defined in seconds."

  "timeout": 120,
  "selections": [
      "frames": [
          "index": 0,
          "excludes": [],...

Hope this helps!

1 Like

@padden Welcome to Distill community!

Some pages require an active tab to show their contents. In the case of Distill’s browser extension, pages are checked in a tab that is not active. If you click on that tab, the contents will load and show up.

Distill’s Desktop app works great for such cases. Can you try it out and set the device to the app for those pages?


1 Like

This timeout parameter could be a huge help to me if I can get it to work. I have incorporated it in the config, but it’s still only getting 30 seconds before it times out.

For cloud monitors,

  1. The default timeout is 30 seconds.
  2. Cloud monitors do not take and apply the value of timeout from the config. So, you can not set timeout for cloud monitors.

For local monitors,

  1. The default timeout value is 60 seconds.
  2. There is no limit for timeout for local monitors. You can set it to any value.

What is the default timeout when nothing is specified in the config?

Can you please share with us the reason to limit the timeout setting to 30 seconds? It is not possible to control the internet connection speed, server response time, design of webpage, etc… Is the check run on it’s own thread or on the main thread? I could see why you would have to limit the timeout for a check if will block other checks/processes.

Hi @raksha, Thanks for replying. Farther up the thread you show an example of “timeout” set to 120. though I understand that the default is 30 seconds. After posting this question, I was able to get the app to acknowledge the “timeout” parameter setting by creating a new monitor for the slow url and setting this parameter at that time. I don’t know if that is what made distill recognize the information, but it is allowing enough time for the url to load now. We scrape the info we are interested in monitoring so that there is no noise and then monitor a page with only the scraped info. Sometimes the scrapes take some time to load.

The default timeout is 30 seconds. I feel like there is conflicting info as the original post suggests setting “timout” to 120 seconds with no mentioned limit. Might just be a miscommunication. I think I have it working now with 300 seconds and I am pretty excited.

1 Like

Sorry about the confusion. I have updated the reply with more details and clarification.

When monitoring part of a page and the page does not show data for a specific time it appears resources on local machine keep getting exhausted maybe until something shows up.
Example, most of the time there is an data element being monitors, but sometimes for hours or day there may not be any data Distill is monitoring.
Is there a timeout to make it so Distill doesn’t stay in an endless loop.
Meaning, have distill check if no data then STOP and wait till nex check time

I think the answer may be to add the Timeout value in Config?
So in my case if 10 seconds passes I know I do not want Distill to care and just wait the next checkin time value
So I would add the following?
“timeout”: 10,


You can try adding the timeout parameter as shown in comment Changing Timeout Length - #3 by raksha. You can use a smaller value instead. But do note that lower timeout value will cause the monitors to error out more frequently.